Зарезервированные диапазоны IP-адресов
Блоки адресов, которые не являются обычными публичными адресами, из реестров специального назначения IANA, и проверка, к какому из них относится адрес.
100.64.12.7 входит в 100.64.0.0/10: Общее адресное пространство (CGNAT).
Блоки специального назначения IPv4
| Блок | Назначение | Определён в | Доступен из интернета |
|---|---|---|---|
| 0.0.0.0/8 | НеуказанныйЭта сеть | RFC 791 | Нет |
| 10.0.0.0/8 | Частная сетьЧастное использование | RFC 1918 | Нет |
| 100.64.0.0/10 | Общее адресное пространство (CGNAT)Общее адресное пространство (CGNAT) | RFC 6598 | Нет |
| 127.0.0.0/8 | Петлевой (loopback)Loopback | RFC 1122 | Нет |
| 169.254.0.0/16 | Локальный для канала (link-local)Link-local | RFC 3927 | Нет |
| 172.16.0.0/12 | Частная сетьЧастное использование | RFC 1918 | Нет |
| 192.0.0.0/24 | Назначен протоколуНазначения протоколов IETF | RFC 6890 | Нет |
| 192.0.2.0/24 | Для документацииДокументация (TEST-NET-1) | RFC 5737 | Нет |
| 192.31.196.0/24 | AnycastAS112-v4 | RFC 7535 | Да |
| 192.52.193.0/24 | Назначен протоколуAMT | RFC 7450 | Да |
| 192.88.99.0/24 | ЗарезервированУстаревший anycast ретрансляторов 6to4 | RFC 7526 | Нет |
| 192.168.0.0/16 | Частная сетьЧастное использование | RFC 1918 | Нет |
| 192.175.48.0/24 | AnycastПрямое делегирование службы AS112 | RFC 7534 | Да |
| 198.18.0.0/15 | Для тестирования производительностиТестирование производительности | RFC 2544 | Нет |
| 198.51.100.0/24 | Для документацииДокументация (TEST-NET-2) | RFC 5737 | Нет |
| 203.0.113.0/24 | Для документацииДокументация (TEST-NET-3) | RFC 5737 | Нет |
| 224.0.0.0/4 | Многоадресная рассылка (multicast)Многоадресная рассылка | RFC 5771 | Нет |
| 240.0.0.0/4 | ЗарезервированЗарезервировано на будущее | RFC 1112 | Нет |
| 255.255.255.255/32 | ШироковещательныйОграниченное широковещание | RFC 919 | Нет |
Блоки специального назначения IPv6
| Блок | Назначение | Определён в | Доступен из интернета |
|---|---|---|---|
| ::/128 | НеуказанныйНеопределённый адрес | RFC 4291 | Нет |
| ::1/128 | Петлевой (loopback)Адрес loopback | RFC 4291 | Нет |
| ::ffff:0:0/96 | Трансляция протоколовАдрес IPv4-mapped | RFC 4291 | Нет |
| 64:ff9b::/96 | Трансляция протоколовТрансляция IPv4–IPv6 (NAT64) | RFC 6052 | Да |
| 64:ff9b:1::/48 | Трансляция протоколовЛокальная трансляция IPv4/IPv6 | RFC 8215 | Нет |
| 100::/64 | ЗарезервированБлок только для отбрасывания | RFC 6666 | Нет |
| 2001::/32 | Трансляция протоколовTEREDO | RFC 4380 | Нет |
| 2001:2::/48 | Для тестирования производительностиТестирование производительности | RFC 5180 | Нет |
| 2001:db8::/32 | Для документацииДокументация | RFC 3849 | Нет |
| 2001:10::/28 | ЗарезервированУстаревший (ORCHID) | RFC 4843 | Нет |
| 2001:20::/28 | Назначен протоколуORCHIDv2 | RFC 7343 | Да |
| 2002::/16 | Трансляция протоколов6to4 | RFC 3056 | Нет |
| 3fff::/20 | Для документацииДокументация | RFC 9637 | Нет |
| 5f00::/16 | Назначен протоколуSID сегментной маршрутизации (SRv6) | RFC 9602 | Нет |
| fc00::/7 | Уникальный локальный (ULA)Уникальный локальный | RFC 4193 | Нет |
| fe80::/10 | Локальный для канала (link-local)Link-local unicast | RFC 4291 | Нет |
| ff00::/8 | Многоадресная рассылка (multicast)Многоадресная рассылка | RFC 4291 | Нет |
По реестрам адресов специального назначения IPv4 и IPv6 IANA, плюс multicast и старый диапазон класса E. Столбец «Доступен из интернета» следует столбцу IANA «globally reachable». Частный адрес никогда не маршрутизируется в публичном интернете.